Cisco Router

cisco route主要內部元件:
RAM(隨機存取記憶體):儲存routing table,arp及快速交換快取,封包緩衝與保留佇列,…
NVRAM(非揮發性的RAM):儲存備份或啟動組態檔,ex:startup-config
flash memory(快閃記憶體):放os映像檔與microcode(微程式碼)
ROM(唯讀記憶體):保留POST指令,儲存啟動的bootstrap程式
interface(介面):serial,ethernet,…等介面 

設定router串列介面
(config)#int < serial interface> //選擇串列介面
(config-if)#ip address < ip> < mask>
(config-if)#clock rate < bps> //設定DCE時脈速率,若是DTE則省略
(config-if)#no shutdown //啟動該介面
在實際情況下,route幾乎是DTE
在實驗環境下,route可以串列線路相連,但其中一邊需設為DCE提供時脈速率
ex:設定serial 1/0介面為DCE,ip為192.168.1.1,mask為255.255.255.0
(config)#int serial 1/0
(config-if)#ip address 192.168.1.1 255.255.255.0
(config-if)#clockrate 56000
(config-if)#no shutdown
ps:show controllers < int>可查看該介面是否有連結DCE纜線

指定頻寬
(config-if)#bandwidth < Kbps>
一些routing protocol會以bandwidth計算metric,改變bandwidth可使路徑改變,ex:eigrp,igrp,ospf…等
ex:指定頻寬為1544k
(config-if)#bandwidth 1544

啟用split-horizon
(config-if)#ip split-horizon
預設為啟用

啟動CIDR技術
(config)#ip classless

允許使用第一個和最後一個子網路
(config)#[no] ip subnet-zero
ps:ios12版後預設為開啟

啟動cisco router IPv6 forwarding
(config)#IPv6 unicast-routing


…………………………………………………………………………………………..

設定靜態路由
(config)#[no] ip route < prefix> < prefix mask> < out ip|out interface> [ad]
[no]為選項參數,若加入則改為刪除靜態路由
prefix表目地網路,prefix mask為目的網路mask
[ad]為選項參數,預設為1,若使用out interface相鄰介面則為0,可設定0-255數值,此值越低表示該路徑越優先
設定完後可在show ip route看到結果
ex:設定192.168.100.0/24的網路由192.168.1.2這個介面過去
(config)#ip route 192.168.100.0 255.255.255.0 192.168.1.2
ex:刪除”192.168.100.0/24的網路由192.168.1.2這個介面過去”這個設定
(config)#no ip route 192.168.100.0 255.255.255.0 192.168.1.2

……….

用靜態路由方式設定預設路由
(config)#ip route 0.0.0.0 0.0.0.0 < ip|interface>
ex:設定預設路由從192.168.1.2這個ip過去
(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.2
ps:
若有多條ip route 0.0.0.0 0.0.0.0指令,流量會自動在多條route上做load balance
load balance可透過traceroute等相關指令去驗證

用動態協定設定預設路由
(config)#ip default-network < network>
會自動宣傳這個預設網路,使其他路由器也會收到此路徑
若路徑表出現R* 0.0.0.0/0 [120/0] via …  表示其他路由器使用ip default-network被rip取得
ps:
igrp中只能用ip default-network,因為igrp無法辨識0.0.0.0

ps:
ip default-network和ip route 0.0.0.0 0.0.0.0同時使用時
若ip default-network設定的network存在該設備上,則成為default route;
若ip default-network設定的network是學來的,則ip route 0.0.0.0 0.0.0.0成為default route。 

……….

設定動態路由,啟用routing protocol
(config)#[no] router < protocol [option]>
[option]在protocol為igrp時,當作as,可自由設定
[no]為選擇性參數,可取消routing protocol
ex:取消rip
(config)#no router rip
ex:取消as值為10的igrp
(config)#no router igrp 10

動態路由注意事項:
執行1個以上的routing protocol可能會浪費頻寬,cpu,記憶體
因為路由器通常只會選擇成本低的protocol,而其他prtocol會被忽略但仍在運作中

ps:
(config)#router ?
 eigrp:Enhanced Interior Gateway Routing Protocol (EIGRP)
 rip :Routing Information Protocol (RIP) 
 igrp :Interior Gateway Routing Protocol (IGRP)
 ospf :Open Shortest Path First (OSPF)
 bgp :Border Gateway Protocol (BGP)
 isis :ISO IS-IS
 word :Route map tag

不要自動總結
(config-router)#no auto-summary
要求eigrp或ripv2不要宣傳此路由器間的所有網路,常用在非連續網路
ps:eigrp和ripv2在classful boundary(有級別的邊界)網路中會自動總結,若用在非連續網路則無法運作
ps:
ripv1,igrp,會自動總結有級別邊界的網路
eigrp,ripv2,會自動總結有級別邊界的網路,要手動支援非連續網路
ospf,不會自動總結有級別邊界的網路,會自動支援非連續網路


…………………………………………………………………………………………..

看所有routing protocol相關資訊
#show ip protocols
可檢查目前在router上所有運作的路由協定的設定

#show run
部份訊息包含路由協定的參數
畫面大致如下
省略…
!
router ospf 1
network 175.10.1.0 0.0.0.255 area 0
network 180.10.1.0 0.0.0.255 area 0
!
省略…

看路由表
>show ip route
顯示出ip路由表的內容,可確認路由器具有到達該網路的路徑
若無法顯示預期取得的路徑,或無任何路徑,可能是路由資訊不能互相交換,應檢查路由協定是否設定錯誤
畫面大致如下
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
 D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
 E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
 i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, * – candidate default
 U – per-user static route
Gateway of last resort is 160.10.1.1 to network 0.0.0.0 
C 192.168.1.0 is directly connected, Ethernet0 //192.168.1.0直接與router的ethernet0相連
S 192.168.100.0 [1/0] via 192.168.1.2,… //192.168.100.0/24的網路由192.168.1.2這個介面過去
S* 0.0.0.0 [1/0] via 160.10.1.1,… //S*為預設路由,其他網路從160.10.1.1界面過去
R 192.168.20.0 [120/2] via 192.168.10.1,…  //動態路由
非直接相連的路徑格式為code ip [ad/metric] via ip,time,interface
ps:執行clear ip route *可清除動態路由在重學

看ipv6的路由表
>show ipv6 route

……………………………………………..


指定ip與mac的對應
(config)#[no] arp < ip> < mac> arpa

查看arp快取
>show arp
畫面大致如下
Protocol Address Age (min) Hardware Addr Type Interface
Internet 197.10.1.1 – 000C.3849.2796 ARPA Ethernet0